Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 17, 2026 - 04:30 UTC
Scheduled
Visibility Eventing Changes:
Production Alerts{} ProductionAlert - 4XX - ERROR - Alert Fix Updated Object Lookup TALOSIPPENDING metrics. Health Service Implemented PIAM JWT support. Stream V3 API Update{} Flash point ticket Addressed Lambda secrets exposure Removed sensitive values from Lambda environment variables and Terraform state. ECS/Fargate secret management Migrated secrets from environment variables to runtime secret injection.{} Tenant-scoped authorization Restricted eventRestAPI tenant configuration GET/PUT operations to tenant-scoped JWTs. Tenant/Device Notification API Removed the hardcoded service-auth key from the codebase and moved it to AWS Secrets Manager. Generated notification API keys using the service ID and a 32-bit random value, encoded with Base64. Provisioned the keys through SSX Core service APIs and stored them in Secrets Manager. Validated incoming keys, extracted the service ID from the authorizer context, and forwarded it to the Notification API. Test security Removed hardcoded tokens from test files. Talos certificate security Removed the Talos certificate password from the codebase and moved it to Secrets Manager. Stream API tenant isolation Restricted stream ID retrieval and patch operations to primary and linked tenants. evtOps stability Fixed an evtOps process crash when notification requests omit linkedTenants. Visibility Eventing SQS security Restricted Visibility Eventing SQS resource policies to the owning AWS account. Removed unnecessary SQS:PurgeQueue permissions.
Posted Sep 09, 2026 - 21:07 UTC
This scheduled maintenance affected: Security Services Exchange Eventing Service - US-EAST-1.